seanw1214

Silent Drag Stradic FL 5K

Rate this topic

11 posts in this topic

Posted (edited) · Report post

Drag on both my Stradic FL 5k's went silent.  They have been fished about 6 times each.  I checked them and both springs are working fine, and the ratchets both look good.  Any idea why?  

Edited by seanw1214

Share this post


Link to post
Share on other sites
21 mins ago, seanw1214 said:

Drag on both my Stradic FL 5k's went silent.  They have been fished about 6 times each.  I checked them and both springs are working fine, and the ratchets both look good.  Any idea why?  

Maybe the spools aren't seated fully?, Just a possibility.

 

HH

Share this post


Link to post
Share on other sites

I’m having a similar problem on my reels. My battle ii 6k had the same issue and then started working again. Very odd. 
 

Going to follow this thread for future reference. 

Share this post


Link to post
Share on other sites
2 hours ago, seanw1214 said:

Drag on both my Stradic FL 5k's went silent.  They have been fished about 6 times each.  I checked them and both springs are working fine, and the ratchets both look good.  Any idea why?  

Upon quick visual inspection It may appear the clicker is not broken but if look closer a small sliver of the clicker tip broke off.

Share this post


Link to post
Share on other sites
1 hour ago, John P said:

I think you have the answer, can you get a replacement part for those reels ?

I looked again.  took both apart and put back together again. one is working now.... the other still isnt.  I will look again to see if the drag clicker is broken.  It doesn't appear to be.  I would try removing 1 spool height washer, but I really don't want to mess with line lay.

Share this post


Link to post
Share on other sites
26 mins ago, seanw1214 said:

I looked again.  took both apart and put back together again. one is working now.... the other still isnt.  I will look again to see if the drag clicker is broken.  It doesn't appear to be.  I would try removing 1 spool height washer, but I really don't want to mess with line lay.

Compare the clicker on both spools because it is very difficult to distinguish a broker clicker. My stradic gave me the silent drag treatment and if it was not for finding a small thin broken piece metal I would not have determined the clicker was broken for that is how difficult it was to see the clicker was broken.

Share this post


Link to post
Share on other sites
27 mins ago, RedSoxTicket said:

Compare the clicker on both spools because it is very difficult to distinguish a broker clicker. My stradic gave me the silent drag treatment and if it was not for finding a small thin broken piece metal I would not have determined the clicker was broken for that is how difficult it was to see the clicker was broken.

it sucks that you buy "Shimano", and not the bottom of the barrel.... and this is an issue?   Never an issue with my Penn spinfisher vi combos

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.