Detcher

VS 100 slight knock

Rate this topic

13 posts in this topic

I have a vs 100 that when you turn the handle there is a slight clunk 3 times during one revolution. if I push in on the handle it goes away. any suggestions?

Share this post


Link to post
Share on other sites

Pull it apart and check the internals. May need a shim hard to say without a inspection. But then again I’m no expert, that’s what I would do to mine if I had that issue. 

Share this post


Link to post
Share on other sites

And you had it serviced?

I ask because I've had mine going on season 5 and I've not had it serviced yet and use it almost exclusively all yr long.  Just recently I noticed a little unusual feeling when reeling and fighting a fish.  Nothing that is causing concern just that maybe some sand may have finally got in. 

Share this post


Link to post
Share on other sites

Check the main shaft that the spool goes on. Remove the spool and turn the handle to extend the spool fully. Clean the shaft and coat it with a light oil other than WD40. Sometimes grease and grime build up on the shaft. 

Share this post


Link to post
Share on other sites
On 7/28/2021 at 3:59 AM, patabate said:

Check the main shaft that the spool goes on. Remove the spool and turn the handle to extend the spool fully. Clean the shaft and coat it with a light oil other than WD40. Sometimes grease and grime build up on the shaft. 

I will try this .Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.