Scubaman

Mercury Outboard external fuel tank

Rate this topic

9 posts in this topic

Hi,  I need some help with my Mercury 2003 5 HP 2 stroke outboard getting the external fuel tank to work. The internal fuel tank works fine and the engine runs very well.  I purchased an external 3 gallon tank with the Mercury connections to the motor.  I turn off the fuel line to the internal and connect the external tank.  The arrows are in the correct direction to send the fuel to the motor.  I also replaced fuel connector on the motor.  The hose and connector to the tank seem to work as air will pass all the way thru to the carburetor.  The problem is that I can't get the fuel to pump thru the line to the motor.  I put more than enough fuel in the external tank.  The squeeze ball works but it just doesn't suck the fuel thru to the motor.  Any ideas on this?  thanks!

Share this post


Link to post
Share on other sites

What HE ^ says, my kid junked a perfectly good older 75 horse because the mechanic was too stupid to try a different hose, and the kid, sadly, is no mechanic.

Share this post


Link to post
Share on other sites

Stonesipher,  thanks for the info.  I do have the arrows in the correct direction and I do have a Moeller type hose and squeeze ball, not the Moeller brand but a knockoff.  What type or brand of hose should I be using?

Share this post


Link to post
Share on other sites
21 mins ago, Scubaman said:

Stonesipher,  thanks for the info.  I do have the arrows in the correct direction and I do have a Moeller type hose and squeeze ball, not the Moeller brand but a knockoff.  What type or brand of hose should I be using?

KML beat me to my first thought...but I've heard tales of problems with cheapo bulbs as well.  I dont think an actual moeller would be problematic, they've always been a decent middle of the road brand

 

Frankly, I'd buy a merc hose.  Aftermarkets never seemed to fit right, always loose, thats coming from someone who spend thousands and thousands and thousands of hours behind small outboards as a kid

Share this post


Link to post
Share on other sites
On 10/12/2020 at 8:18 AM, Scubaman said:

Stonesipher,  thanks for the info.  I do have the arrows in the correct direction and I do have a Moeller type hose and squeeze ball, not the Moeller brand but a knockoff.  What type or brand of hose should I be using?

Any of the factory brands like yam , merc, suxuki will do Honda’s ate fine but will be the most expensive 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.