dawgfsh

Saragossa SWA

Rate this topic

55 posts in this topic

Here in SA the 14000 size was the biggest "missing link"

The most popular size Stella or Twinpower in SA, by a long shot, is the 14k

Share this post


Link to post
Share on other sites
4 hours ago, patfont said:

On the subject of SW vs SWA Maybe I am missing what makes the difference in parts for Infinity Drive? On the SWA scat?

 

 

I could be proven dead wrong, but I suspect it is a combination of gear tooth design and the plastic bushing into which the bearing at the end of the pinion is inserted which (should) isolate vibration(s)  - as an example RD21305 for the 14000 size

Edited by ZAFisher

Share this post


Link to post
Share on other sites

Got a bit sidetracked today

No albies or tog but I spent he day chasing blitzing stripers 

Waist deep in water, with some swell that definitely washed over the reel 

Definitely put it through it's paces and it kept ticking 

We'll see if it holds up long term, but very happy so far 

 

Share this post


Link to post
Share on other sites
On 10/3/2020 at 7:36 AM, patfont said:

On the subject of SW vs SWA Maybe I am missing what makes the difference in parts for Infinity Drive? On the SWA scat?

 

 

I swear it's a $. 01 bushing below the lower pinion support bearing with a bore size just greater than the spool shaft. 

This makes sure the shaft stays 100 percent on plane.. Without any deviation that robs efficiency... 

Sounds silly.. But that **** makes a difference 

Share this post


Link to post
Share on other sites
14 hours ago, scoobydoo said:

I swear it's a $. 01 bushing below the lower pinion support bearing with a bore size just greater than the spool shaft. 

This makes sure the shaft stays 100 percent on plane.. Without any deviation that robs efficiency... 

Sounds silly.. But that **** makes a difference 

LOL, TY!

Share this post


Link to post
Share on other sites

Anyone else with one have a "silent" drag at times?

Noticed when drag is being pulled at high rate of speed ( think albies, or on a hard hookset etc)  the clicker doesn't click? 

Drag is still smooth and doing its job, and it's only happened to me a few seconds at a time 

It's not a problem per say but just curious if anyone else is running into this 

 

Share this post


Link to post
Share on other sites
On 10/10/2020 at 4:09 AM, GrahamN said:

Anyone else with one have a "silent" drag at times?

Noticed when drag is being pulled at high rate of speed ( think albies, or on a hard hookset etc)  the clicker doesn't click? 

Drag is still smooth and doing its job, and it's only happened to me a few seconds at a time 

It's not a problem per say but just curious if anyone else is running into this 

 

mine.. the drag sound isnt constant..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.