salvadore33

Penn spinfisher V 4500 difficult to reel under load

Rate this topic

3 posts in this topic

Hey fellas

 

I've had this reel for several years now but stopped using it for the past two years because of the hard grinding I would experience once I use it under load. It reels freely when it's not pulling weight but once I attach a 3oz plug to my line it is a labor to reel in. I've already replaced the main gear and pinion with the new machined gear set Penn had fabricated.

 

Ive replaced the oscillation gear and block even updated the bearings under the rotor and still nothing improves its performance. I wanted to know if anyone has similar experience and found the solution to this issue. I would have mailed to Penn for servicing but the caronavirus situation has halted there repair service so I'm left having to figure it out. Any help would be appreciated.

 

Lue 

Share this post


Link to post
Share on other sites

Check the line roller bearing / bushing it may be frozen so when pressure is put on it while retrieving plugs it will get hard to reel 

Share this post


Link to post
Share on other sites
23 mins ago, Dave RI said:

Check the line roller bearing / bushing it may be frozen so when pressure is put on it while retrieving plugs it will get hard to reel 

Thanks I dulled it out today it still seems functional but I'll give it a soak in penetrating oil just to be safe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.