levari

ZeeBaas too tight

Rate this topic

7 posts in this topic

Posted (edited) · Report post

I know the tightness is coming from the clutch assembly. I tested it without the clutch house assembly and no issue. I also test it by running the shaft through the pinion gear and those seals are also  not the issue. 

The bearing in the clutch assembly is perfectly fine.

 

Does the clutch itself can be the root cause or Is it the seal in the clutch assembly?

 

It must be one or the other.

 

Edited by levari

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You took the clutch out put clutch back and remove the seal and try again.

lt's trial and era at this point unless you have parts to swap.

Edited by LB

Share this post


Link to post
Share on other sites
3 hours ago, LB said:

You took the clutch out put clutch back and remove the seal and try again.

lt's trial and era at this point unless you have parts to swap.

I thought about it but then I will need to get a new seal even if the issue is not the seal. I called ZB and they will take a look.. thx

Share this post


Link to post
Share on other sites

I sent it to ZeeBass and they fixed the issue free of charge. I am still trying to figure out from them the root cause. As always the service was superb and fast

Share this post


Link to post
Share on other sites

If only..

those that repair made written explanations what was the cause and how they`ve fixed it.

It would eventually decrease reclamations so much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.