Jimo95

Battle 2 5000 problem

11 posts in this topic

Bought a Battle 2 5000 six months ago and fished through the fall.  Reel was fine at end of the season and recently when I reel it, there is a “whizzing” noise coming from the reel.  Can’t tell if it’s the gear or pinion.  It is not stiff and does not seize up, just noisy.  Any suggestions would be appreciated

Share this post


Link to post
Share on other sites

Jim,

 

Sounds like the backup a/r # 10 and # 12 on the schematic.  You need to remove the rotor to access the parts.  Since the reel is less than a year old it would be covered under warranty if you want to send it in, or you can work on yourself by hooking the spring back in (very easy to do). 

 

tony

Share this post


Link to post
Share on other sites

I will look at it again but everything seemed normal when I took it apart.  The part of the spring(#10) that points upward was in the hole on part #12.  I heard that if needed, these parts can be removed but then the a/r would not  have a backup.  I tried to remove these, but the rotor would not fit properly.  Easier just to buy these new parts?  I live 2 minutes from Mystic Reel Parts.

Share this post


Link to post
Share on other sites

Yes they can be removed, those 2 parts being removed should still allow the rotor to fit properly.  Scott's is a good option, I would let one of the repair Tech's hear the sound first, they may be able to confirm just by the sound if the backup ratchet is the cause.

 

tony

Share this post


Link to post
Share on other sites

I took it apart again and found the source.  The bottom of the pinion is touching the plastic piece right underneath it and I can’t figure out why.  When the pinion spins it makes the noise.  There is a little play up and down with the pinion but don’t know how to make it so it’s raised ever so slightly.  

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

The Battle Il'S seem to be garbage.  I have a 1000 that does the same thing after minimal use minimal fish fighting iin freshwater.  I won't buy any more.

Edited by DrBob

Share this post


Link to post
Share on other sites

Sorry you feel that way Bob.  The original post is referencing the backup ratchet and spring.  The 1000 size reels do not have these parts so whatever the issue you are having in unrelated.  We will be happy to take a look at the reel for you if you would like. 

 

tony

Share this post


Link to post
Share on other sites

If this was the only problem I encounter than I don't mind one bit.  $1.00 for the part and it's back to normal.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.