sauerkraut

F-150: Idiot Lights

27 posts in this topic

I 3rd the code reader those thing's are getting better and less expensive. Wow $11000...years back my work had the dealer replace a 6.8 v10 on a passenger van. They took the whole body off the chassis to access the engine cost was $8000

Share this post


Link to post
Share on other sites

If you are changing the oil every 5,000 miles, the Ford oil reminder comes on at at 7500 miles, my company changed our oil intervals for our small trucks F-150 to

F-450 to 7500 miles from 5,000. I get the oil alerts a few days before it is due, you changed oil at 5,000 miles and drove 2,000 more until oil alert came on,they didn't reset. My electricians run their trucks about 40,000 a year and we run them to about 450,000 before retiring......Jack

Share this post


Link to post
Share on other sites
6 hours ago, Mark L said:

I was gonna ask if they did the leak down test, which is pointing toward the valves. Now if they put oil in the cylinder, performed the leak down test or compression test again and leakage went down compression goes up then it’s piston rings. If it stayed the same then it’s a valve issue. Sometimes it could just be carbon build up on the valves or worse case burnt valves. There’s a lot going on here with your engine but it doesn’t sound like it’s shot. You can try a carbon service, throw a bottle of marvel mystery oil in gas and one in the engine. Don’t ask why the stuff is a Mystery but it works magic. Good luck

1.  Thank you for this Mr. L.  Glad I posted the readout, and you saw it.  OK:  valves or rings.  I will throw some Marvel Mystery Oil at the issue. 

2.  As I stated, when I did my own oil change over the weekend, I caught and saved a quart or so mid drainage.  Can oil analysis be of any       diagnostic or prognostic help here ??

3.  I agree with the other commentator, that it is possible the Stealership, when they last did my oil change, did not reset the oil life indicator-- thus creating another False Positive alarm for this amateur only 2,000 miles later. 

 

4.  I will be off this Thread for a little while:  In an hour, I am leaving for BOS Logan, a 70 mile drive (in my still running perfectly, engine service light still on F-150), and abandoning the vehicle for 8 days.  I appreciate all of the help and advice so far.  This is an unresolved issue.  We really do not know yet if I have just an "issue" Idiot Lights, or a "problem".  And if this is a "problem", is it a little one or a big one needing a new vehicle or a re power new engine.  You will be informed.

Bonds,

Alan SauerKraut

IMG_0035.JPG

Share this post


Link to post
Share on other sites

Post this on one of those F150 forums.  Will get better visibility without the 'get a new gas cap' responses which seems to be the universal fix for the dreaded CEL. Except you don't have a gas cap on your truck. :laugh:  

 

I have the same exact model year and enginer as you do and pushing 130k.  It has run flawlessly so i'm very interested in the outcome of this.

Share this post


Link to post
Share on other sites
On January 14, 2020 at 6:01 PM, sauerkraut said:

Thank you all for the help.  

1.  No, the service engine light NOT flashing.

2.  Somebody else mentioned a faulty gas cap issue.  However, the F-150 does not have a gas cap per se-- rather a flapper valve.

3.  The Ford Dealership/Stealership original code read:   See Attachment.

IMG_7075.JPG

Thank them. They saved you tons of bs. 

Share this post


Link to post
Share on other sites
13 hours ago, ted527 said:

I would get the code reader, good chance you have another spark pack going out.

Yeah, Bad spark plugs are like stripers...... where there's 1 there's usually always others.:laugh:

Share this post


Link to post
Share on other sites

Thank you, Fly By Nite, and others for this followup information.

I am back from traveling; therefore back on this Thread and site. 

The vehicle did just fine getting me up and back home from BOS Logan Airport last night-- and having been abandoned in Parking for 8 days in between.  I will continue this pursuit.

Share this post


Link to post
Share on other sites
On 1/15/2020 at 10:57 AM, Fly By Nite said:

Post this on one of those F150 forums.  Will get better visibility without the 'get a new gas cap' responses which seems to be the universal fix for the dreaded CEL. Except you don't have a gas cap on your truck. :laugh:  

 

I have the same exact model year and enginer as you do and pushing 130k.  It has run flawlessly so i'm very interested in the outcome of this.

 

Thank you, Mr. FBN.

I did register to F150online.com, and posted this issue:  F150online Forums > Powertrain & Mechanical > V8 Engines.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.