Fishee

Out of the box: Penn Slammer 8500HS drag issue

Rate this topic

8 posts in this topic

Hi all,

i decided to pull trigger on a brand new Penn Slammer 8500hs for everything from land based shark fishing to throwing big metal and poppers. Straight out of the box I noticed a very weird creaking/grinding sound when turning the spool against the drag (almost sounds like somebody snoring). I thought lining it up and pulling out drag might spread some grease around might fix it but to no avail. Has anybody dealt with this or have any suggestions? I will try to upload a video.

Thank you in advance for the help.

-Dan

Share this post


Link to post
Share on other sites

sounds like clutch chatter to me,,like it's dry..

might need some lubing.

did you try taking the spool off and looking?

maybe something is not set right.

give it a few drops of oil .

I'd try something simple since I am not anal.

HH

Edited by Heavy Hooksetter

Share this post


Link to post
Share on other sites

the reel vibrates when that noise is happening?

the drag has to be dry,,not sure if it is supposed to be oiled at all but,if it vibes,it's dry.

comes from the friction.

had almost the same sound with a vibe with my Calcutta 700-b when I swapped the drag to carbons.

first fish to take line fixed that.

HH

Edited by Heavy Hooksetter

Share this post


Link to post
Share on other sites

Thanks all, Pierce that thread is very helpful. The spool does vibrate when that noise happens but I see no signs of rubbing or scrapping on any internals. I'm going to send it back and hopefully the next one wont have any problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.