Sign in to follow this  
Followers 0
Twohand

Fuel system question 06 Yamaha F250

Rate this topic

3 posts in this topic

I have twin F250 Yamahas, last week port engine would not go over 3000 rpm, starboard engine ok. Back to slip to change engine filters, 2 on each engine, and the Racors,1 each. After change engine fuel bowls would pump up full and primer bulb went hard. Once engines were started fuel bowl level would drop about 2" and would not refill, both engines seemed to run/idle fine. Ran them both up to about 2500 in neutral, both seemed fine. Did not take boat out as it was late in day.

Never noticed this fuel bowl level drop before, but never  paid much attention as engines ran fine. Is it normal for this level drop to occur or does it indicate a problem.

 Thanks

 Greg 

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Did u manually prime/fill new racors or rely on fuel pumps? If so may have damaged fuel pump on motor. Also double check primer bulbs

Edited by ChuckieP

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

pumped up fuel system racors and primary engine filter before starting. If pump was damaged wouldn't the primary fuel bowl stay full and not drop upon start.

Edited by Twohand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.