Sign in to follow this  
Followers 0
MatthewG

Penn Spinfisher VI 6500LC Clicking Noise on retrieve?

2 posts in this topic

Hello,

 

I recently just purchased the Penn Spinfisher VI 6500 LC and had a chance to try it out over the weekend. I am really impressed with this reel so far, seems super smooth, casting is great and seems to be of great quality. Only one issue I am having so far, basically right out of the box when retrieving I am hearing a clicking noise. This only seems to happen when I have a fish on or if there is extra weight on the retrieve etc, anything over say 5 ounces seems to cause this clicking noise at all times during retrieve.

 

One odd thing is, it doesn't seem to happen every time but its somewhat frequent, also it does not seem to impede the retrieve at all, what I mean is the retrieve seems super smooth but you can definitely here the clicking.

 

My question is, did I perhaps get a defected reel? I did pay over $300 for it and am worried it might get worse or cause a performance issue with the reel ? If its just a clicking noise and want cause issues it doesn't bother me.

 

Thoughts?

Share this post


Link to post
Share on other sites

Matthew,

 

When the spool reaches the highest/lowest point, the Osc. slider (part # 43 on the schematic) rocks slightly giving off a click.  However if it is happening during the entire retrieve something else might be wrong.  Can you confirm?  Thanks. 

 

tony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.