GP100

Slammer III Noise?

Rate this topic

5 posts in this topic

I've been moving my 5500 between my surf rod and a boat rod until I decide on either getting a second one one of something different for the boat. While surf fishing and doing well with schoolies a week or two back I noticed when not hooked up that the reel was making a high pitched whine when reeling in. I forgot about it and went out a couple times this weekend. Ran into some large blues on saturday while on the boat, I didn't notice the noise and the reel handled the fish (7-10 lbs or so) well. Yesterday, after having my albie snax attacked by a smaller blue (~4-5 lbs) on a lighter outfit i grabbed the slammer set up with a diamond jig. I didn't hook up, but when reeling quickly the noise was back, and loud. I just Checked the reel out in the garage, it seems fine when cranking the handle fast, but I didn't have any line out or tension on it. Could it be the roller? the roller seems to spin freely. I gave it a drop of oil anyway. Has anyone had this issue and if so, what was causing it? 

Share this post


Link to post
Share on other sites

Yes it could be the roller. I believe they have replaced the roller bushing with a bearing on newer versions. Take the roller apart and look for corrosion. 

Share this post


Link to post
Share on other sites

Try flossing the line roller with a length of line running back and forth on the roller..

 

 

what shape is the ramp of the line roller where the line runs on 

is it flat or rounded

 

Flat i believe it's a bearing...rounded it's a bushing.

 

If it's a bushing take it out and clean it and add a bit of oil or cut grease.

 

If it's a bearing.  I'd say take it out and try to squeeze some oil in past the shield (removing such a small shield will likely compromise it )

Either way make sure you clean it well as it could be debris running on the spacers.

 

 

Share this post


Link to post
Share on other sites
On 9/5/2018 at 1:47 AM, scoobydoo said:

Try flossing the line roller with a length of line running back and forth on the roller..

 

 

what shape is the ramp of the line roller where the line runs on 

is it flat or rounded

 

Flat i believe it's a bearing...rounded it's a bushing.

 

If it's a bushing take it out and clean it and add a bit of oil or cut grease.

 

If it's a bearing.  I'd say take it out and try to squeeze some oil in past the shield (removing such a small shield will likely compromise it )

Either way make sure you clean it well as it could be debris running on the spacers.

 

 

Not sure what you mean by the ramp of the roller. The gold ramp is curved but the silver roller in the center looks flat. When did they start using bearings? I bought the reel in November of 16. 

 

Tried flossing the roller with a rubber band and then a length of line, not sure I was able to spin it long and fast enough to replicate the problem. I will take it apart when I have a few free minutes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.