Sign in to follow this  
Followers 0
Milemaker13

o-rings on the old prestolite trim pump

Rate this topic

3 posts in this topic

Hey Gang!  Its been quite some time since I've been around, but I could use a little advice. 

I have a 1978 cobalt with a 165 mercruiser MC.  It has what appears to be a prestolite trim pump.  Round motor, square res...  I think it is the "high pressure, low volume" type pump.  

Anyway, it has started leaking.  I have not yet been able to watch the drip as someone else operates the switch...  but I'm hoping the most likely cause it the o-rings under the "dogbone" valve body. 

I'd like to replace them, but would rather not remove the pump if possible.  Can I feasibly change these o-rings with the pump installed? Of course the pump is hidden away back behind the seats and motor box... its a tight fit...  

What do you guys think?  Or, is it going to just be easier to pull the pump?  

Now, I've also read several accounts of guys thinking the pump needs replacement (or being told that by mechanics) but all they did was tighten the bolts and hose connections and fixed their leaks.  I should probably try that first, huh?  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.