StriperSwiper357

Penn SSVLL rear drag issue

Rate this topic

3 posts in this topic

I went fishing last Friday and started to have an issue with thr rear drag (live liner drag). Front drag was set tight while the rear drag was set loose. After fishing for a bit the rear drag didn't seem to work at all. I flipped the rear drag switch off and on a bunch of times and it seemed like it was set tight like the front drag. I was able to turn the rear drag knob, but it didn't make any diffence. After hooking a fish I was reeling in and i had trouble reeling in my line. The reel made a sound like the drag was on every now and then! Anyone have any experience with the liveliner drag on these reels?

Share this post


Link to post
Share on other sites

I have to repair these all the time. Yours is an easy fix hopefully.

Remove the side cover carefully so the cam for the LL stays in the body of the reel. The pot metal part sticking out of the hole in the cover.

The action that switches the LL is all in the side cover. There is a part called the "dog" that slides back and forth. Its stuck.

Clean everything really well and oil it. Slide it back and forth to make sure it doesn't stick. Now you can grease the side cover and reinstall.

Before putting the cover on turn the spool shaft while watching the rear drag ratchet. The dog slides into notches in that ratchet. Turn it until you see the notch between each tooth. The cover will go on without any interference. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.