Sign in to follow this  
Followers 0
Bass Ackwards

Comcast TV users

Rate this topic

9 posts in this topic

Do you have sound on all your chanels? Three TVs in the house, all with the same problem, sound on some channels, no sound on other channels. Anybody else have this problem?

Share this post


Link to post
Share on other sites


I had that problem once with a TV in the bedroom.  We don't have a cable box on that TV and use the little black one Comcast gives you.  Apparently there is a "language" botton on the bottom that someone had pressed, slept on.  If that's what you did, keep pressing that button until it brings you back to English.


Share this post


Link to post
Share on other sites

Just flipping through the channels I get sound (in english) on most channels, no sound on others. I don't have a cable box, just the little ones on each TV.

Share this post


Link to post
Share on other sites

 

 

Quote:

Originally Posted by Bass Ackwards View Post

 

Just flipping through the channels I get sound (in english) on most channels, no sound on others. I don't have a cable box, just the little ones on each TV.

 

Did you try pressing the "langauage" button on the comcast remote?  I had the exact same problem.  Sound on some channels, no sound on others, and on some channels the background music could be heard, but not the dialogue.

 

 

 

Share this post


Link to post
Share on other sites

 

 

 

Did you try pressing the "langauage" button on the comcast remote?  I had the exact same problem.  Sound on some channels, no sound on others, and on some channels the background music could be heard, but not the dialogue.

 

 

Yes I did, made no difference.

Share this post


Link to post
Share on other sites

 

 

 

Did you try pressing the "langauage" button on the comcast remote?  I had the exact same problem.  Sound on some channels, no sound on others, and on some channels the background music could be heard, but not the dialogue.

 

 

Yes I did, made no difference.

 

So after thinking about it I probably didn't. I tried channel 8 which had no sound, then it the language button and sound...and in english. I'll try the rest later. Thanks north-shore. :th:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.