Sign in to follow this  
Followers 0
epanzella

Yam F115 Waterpump help

Rate this topic

6 posts in this topic

changing the waterpums on my Yam F115's as we speak and the plastic fitting the speedo hose attaches to crumbled to pieces. Can I ignore this or does it perform some other function besides the speedo.

Share this post


Link to post
Share on other sites

the fitting is plastic and threads into the lower unit next to the waterpump and shifter. The speedo hose comes from the upper unit and connects to it. I don't use a speedo but I wonder if they take water pressure or temp reading off that source. The engines are 2004 F-115's.

Share this post


Link to post
Share on other sites

I am pretty sure it is just for the speedo. It is easy to replace, that would be the option that I would go with. If you don't want to replace I would still get it out and plug the hole with a stainless or plastic screw of the correct size.

I would not just leave it open.

Share this post


Link to post
Share on other sites

Its just for speedo sensor. I agree about plugging the inlet or the fitting if you aren't going to fix it. Otherwise water will enter the housing.

Share this post


Link to post
Share on other sites

I ended up biting the bullet and drove to the dealer. Paying 5 bucks for a 39 cent plastic part is one of life's great pleasures. Thanks for the help, guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.