Sign in to follow this  
Followers 0
chicky

another avet question

Rate this topic

10 posts in this topic

I just picked up an avet sx from a friend with very little use. problem is there is not much drag. I'm thinking the additional drag knob adjustment on the handle was probably played with while not completely in free spool.

anyone have any quick solutions for this before I open her up and check out the drag washers?

Thanks

R

Share this post


Link to post
Share on other sites

The washer (one) is supposed to be completely dry. Thats how they ship it out. Good advice about Alan Tani. Visit his web page. How much drag is "not much"? Did you check with a spring scale?

Share this post


Link to post
Share on other sites
View PostThe washer (one) is supposed to be completely dry. Thats how they ship it out. Good advice about Alan Tani. Visit his web page. How much drag is "not much"? Did you check with a spring scale?

 

there was about 3 pounds of drag at max. maybe enough for a good sized trout

Share this post


Link to post
Share on other sites

last one i servised i used a pick to get the carbon disk off, it was all white and salty. used breakfree and other solvents to clean it, soaked it in another degreaser to get all oil/salt off it dried it and greased it up worked like new.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.