Sign in to follow this  
Followers 0
coppertrout

car trouble

Rate this topic

16 posts in this topic

we had a brutal cold snap a few weeks ago and the battery in my wifes 01 voyager died. after getting a new one the dash lights and speedometer don't work?? went threw all the fuses, all ok. only one fuse box in the engion compartment? which i thought was strange. went to a bunch of sites and read something about resetting the computer? i've done this on other cars by disconnecting the battery and turning the ignition on for 15 minutes or so. didn't do a thing? i am stumped.

Share this post


Link to post
Share on other sites

Googled up this info, hope it helps ya (I think "BCM" is body computer module):

Hi ... Yesterday my 1996 Grand Caravan Se gave me a surprise when I turned on the car. None of the dash panel indicators are working. The speedometer stays at zero while I"m driving. The gas gauge is stuck where it was before I drove and filled up the tank. The gear indicators are gone too; so I don't see which gear I'm in.

....

I was hoping for any/all suggestions before taking it to get fixed somewhere.

 

Thanks,

Kathy

 

 

Open your hood and look for the fuse and relay center just above the battery . open the cover and look for a fuse called IOD usually towards the top of the block , they are labeled . Remove the IOD fuse for 20 seconds and then reinsert . The BCM becomes hung and this will reset it in a lot of cases . Let us know how it works out .

 

 

That's just what it was! The panel is just fine now! Thanks so much!

Kathy

Share this post


Link to post
Share on other sites
View Postdisconnect both battery cables and hold them together for 30 seconds. re connect the battery and you should be all set.

 

I knew that! biggrin.gif

Share this post


Link to post
Share on other sites
View PostGoogled up this info, hope it helps ya (I think "BCM" is body computer module):

Hi ... Yesterday my 1996 Grand Caravan Se gave me a surprise when I turned on the car. None of the dash panel indicators are working. The speedometer stays at zero while I"m driving. The gas gauge is stuck where it was before I drove and filled up the tank. The gear indicators are gone too; so I don't see which gear I'm in.

....

I was hoping for any/all suggestions before taking it to get fixed somewhere.

 

Thanks,

Kathy

 

 

Open your hood and look for the fuse and relay center just above the battery . open the cover and look for a fuse called IOD usually towards the top of the block , they are labeled . Remove the IOD fuse for 20 seconds and then reinsert . The BCM becomes hung and this will reset it in a lot of cases . Let us know how it works out .

 

 

That's just what it was! The panel is just fine now! Thanks so much!

Kathy

 

that should be ur prob and double check the fuse while u got it out

Share this post


Link to post
Share on other sites
View PostHow'd ya make out,was it a certin battery proto call apon install or was it the altinator?

 

 

 

headscratch.gif huh?

 

looked for the relay first but found none labeled IOD. did the battery cable thing and i have the dash lights back (thank you very much) but still no speedometer. guess i'll go get the manual and read about the battery.

 

oh, lol thats what you are talking about.

 

you know how you dissconect the battery to check and see if the altinator is putting out enough? i was told not to do that with these newer vehicles?

Share this post


Link to post
Share on other sites
View Postheadscratch.gif huh?

 

looked for the relay first but found none labeled IOD. did the battery cable thing and i have the dash lights back (thank you very much) but still no speedometer. guess i'll go get the manual and read about the battery.

 

oh, lol thats what you are talking about.

 

you know how you dissconect the battery to check and see if the altinator is putting out enough? i was told not to do that with these newer vehicles?

 

 

What did your owners manual mention about battery change out,if you have done everything by the book your car should be ok,unless there must be some kind of reseting proto call,if not maybe your PCM "Primary control module" could have issues.

Share this post


Link to post
Share on other sites
View PostWhat did your owners manual mention about battery change out,if you have done everything by the book your car should be ok,unless there must be some kind of reseting proto call,if not maybe your PCM "Primary control module" could have issues.

 

 

owners manual has nothing about battery change out.

 

went back out last night and found that fuse, they hid it right in front of me. still don't have the speedometer?

 

btw thanks clapping.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to register here in order to participate.

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.