Search the Community

Showing results for tags 'envirotex lite'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • New Features
  • Other

Forums

  • Stripers Online Forums
    • Main Forum
    • Fly Fishing
    • Boating and Boat Fishing
    • Freshwater Fishing
    • Kayaking and Kayak Fishing Forum
    • Beach Buggy Forum
    • Fishing Industry Insiders
    • Tackle Collectors
    • Buy/Sell/Trade Forums
    • Commercial BST Forum
  • Community Forums
    • The Town Tavern
    • Sports Forum
    • Political Graffiti
    • The Enfield Forum
    • The Real Outpost
    • Memorial Forum
    • Food Fling Forum
    • Bugs, Issues and Platform Comments
  • How-To Forums
    • Do It Yourself
    • Outdoors Digital Photography and Video
    • Rod Building Forum
    • Fly Tying Forum
    • Lure Building
    • Steve‚Äôs Cooking Your Catch
    • Distance Casting Forum
    • Reel Maintenance and Repair
  • Regional Forums
    • Coastal Maine/NH Fishing
    • Massachusetts Fishing
    • Rhode Island Fishing
    • Connecticut Fishing
    • Long Island/NY Fishing
    • New Jersey Fishing
    • Pennsylvania Fishing
    • DelMarVa Fishing Forum
    • Chesapeake Bay Fishing
    • Hatteras/OBX Fishing
    • Florida Fishing
    • West Coast Fishing
    • Bottom Fishing
  • Clubs and Organizations
    • Ditch Trolls

Found 1 result

  1. Hi I am in the process of completing another 3 lures, while doing top coating with envirotex lite I came across following problems not able to sort out. How I did it ; First I clean the lures with rubbing alcohol and put them on my drying wheel. Mixed resin & hardener thoroughly for 4 minutes before applying on the lure and start my drying wheel. After 15 minutes I use hair drier to blow away air bubbles if any. Kept the lures on drying wheel for 4-5 hours and then stop keeping the lures still on the drying wheel for curing. The coat was uneven at all the places with small pots and lumps at few places. After 72 hours I sanded the lures lightly and tried putting thick coat and the end result top & sides of lures were nicely finished but the belly is in bad shape with pots at few places & lumps. Here are the pictures : Would appreciate if some one advise me where I went wrong and how to correct the belly now. Thanks & Regards, Raghubir