Search the Community

Showing results for tags 'Battle2'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • New Features
  • Other

Forums

  • Stripers Online Forums
    • Main Forum
    • Fly Fishing
    • Boating and Boat Fishing
    • Freshwater Fishing
    • Kayaking and Kayak Fishing Forum
    • Beach Buggy Forum
    • Fishing Industry Insiders
    • Tackle Collectors
    • Buy/Sell/Trade Forums
    • Commercial BST Forum
  • Community Forums
    • The Town Tavern
    • Food Fling Forum
    • Sports Forum
    • Political Graffiti
    • The Enfield Forum
    • The Real Outpost
    • Memorial Forum
    • Bugs, Issues and Platform Comments
  • How-To Forums
    • Do It Yourself
    • Outdoors Digital Photography and Video
    • Rod Building Forum
    • Fly Tying Forum
    • Lure Building
    • Cooking Your Catch
    • Distance Casting Forum
    • Reel Maintenance and Repair
  • Regional Forums
    • Coastal Maine/NH Fishing
    • Massachusetts Fishing
    • Rhode Island Fishing
    • Connecticut Fishing
    • Long Island/NY Fishing
    • New Jersey Fishing
    • Pennsylvania Fishing
    • DelMarVa Fishing Forum
    • Chesapeake Bay Fishing
    • Hatteras/OBX Fishing
    • Florida Fishing
    • West Coast Fishing
    • Bottom Fishing
  • Clubs and Organizations
    • Ditch Trolls

Found 2 results

  1. Firstly my apologies to admin for originally posting in perhaps the wrong section of this forum. My story is that i started using a Battle 2 3000 with spiderwire on my 7' Ugly Stik Elite last week. Filled spool to approx 80% capacity. Terribly bothered with wind knots. Probably lost approx 30 metres line already. Line lay on spool looked fine so did not bother with either of spare washers in box. Seems to be spilling line over lip of spool as i retrieve which results in a right 'birds nest' on next cast. I do not close bail arm manually as I prefer to do this by hitting my distance and closing bail by turning handle. Would you advise trying a different brand of braid or perhaps changing or adding one or both of the spare washers? I have used quite a few brands of reel in my time and never had this issue! I love the smooth action of my Penn Battle 2 but I am really at my wits end! Thanks in advance. Bryan.
  2. Hi, having problems with spiderwire braid looping over top of spool lip on retrieval. Have lost approx 30 mts braid on my first 2 outings. Now im anxious about refilling the spool in case it happens again! Reel used as it was out of box. Would either of the spare washers that came with it help sort out this problem? TIA, Bryan