Jump to content


Photo

Chevy truck gas tank won't fill


  • Please log in to reply
18 replies to this topic

#1 crabbypatty

crabbypatty

    1,000 Post Club!

  • Users
  • PipPipPipPipPip
  • 1,170 posts
  • Joined: Aug-12 2008

Posted March 06 2010 - 12:45 PM

I just wanted to post this so it may help someone else out who has this problem. My 05 2500 hd silverado had a check engine light on, which when read by a scanner said "evap, large leak" So I ignored it and contiued to drive it. Then recently I would stop to fill er up and the tank wouldn't take gas at any more than a snails pace. It would keep tripping the pump cause the fuel would back up and gurgle in the filler neck. I asked around and that code usually means there is a solinoid valve on the back of the tank that is bad, due to dust getting in it. No one could verify if that was also my tank filling problem. The new improved valve is $150.00 plus some hose clamps and about 12 feet of 5/8 heater hose. So I bit the bullet and bought the parts. I put it on the lift and replaced the valve and routed the hose and filter to above the tranny, which is supposed to be cleaner than the air behind the tank. I went to the gas station and filled her up, no problem! Had the code reset and it hopefully should be fine. I was also told that if you overfill the tank, and top it off, it could flood the valve with raw gas, instead of just fumes, which will damage the valve, so I will not be topping off my tank anymore. Lesson leaned! Let me know if you have had a similar experience, as this is a common problem with '99 thru 2010 Chevy trucks.
Quote:Originally Posted by HugeDinghythe internet may have ruined fishing, but it has blessed us with free porn...let's call it a push...

#2 Eagles Dare

Eagles Dare

    Way too many!

  • BST Users
  • PipPipPipPipPipPipPip
  • 19,597 posts
  • Joined: Aug-18 2006
  • LocationA canal rock or a Western MA treestand

Posted March 07 2010 - 11:26 AM

I had a similar problem last summer, but it was with my daughter's Nissan Sentra. Was able to just take it apart, clean and lube it up, and it's been working fine ever since.
I'll have mine on the rocks.

#3 tonymo

tonymo

    Elite Member

  • Users
  • PipPipPipPip
  • 824 posts
  • Joined: Jul-08 2006

Posted March 07 2010 - 10:23 PM

In my 05' 1500, I recently had the filler cap and valve replaced because the light was on. But the issue with the tank not taking fuel only seems to pop up as a random issue when the tank is very low.

#4 dogboy

dogboy

    Way too many!

  • Users
  • PipPipPipPipPipPipPip
  • 11,798 posts
  • Joined: Aug-21 2004

Posted March 08 2010 - 8:15 AM

apparently there is a charcoal filter that can get clogged from overfilling

then, as you try to fill the tank, the displaced air cannot escape and the fill tube tries to
"burp" it out, causing back pressure that trips the gas pump shut off

#5 crabbypatty

crabbypatty

    1,000 Post Club!

  • Users
  • PipPipPipPipPip
  • 1,170 posts
  • Joined: Aug-12 2008

Posted March 08 2010 - 9:11 AM

Usually people will swap the filler cap, just because it could be the problem and it is a cheep fix. Unfortunately it isn't the problem most of the time.
Quote:Originally Posted by HugeDinghythe internet may have ruined fishing, but it has blessed us with free porn...let's call it a push...

#6 gomab22

gomab22

    New Member

  • Users
  • Pip
  • 4 posts
  • Joined: Sep-28 2012

Posted September 28 2012 - 10:39 PM


Hi! I recently bought a 2005 chevy tahoe......for some odd reason I can't fill my tank. I know this vehicle should take around 22-25 gallons. I can only pump 9-12 gallons before the nozzle pops (indicating my tank is full)....once I start my vehicle it's only on 1/2 tank! which is really frustrating.....can anyone lead me in the right direction to rectify this problem.....thank you.



#7 longcaster

longcaster

    Way too many!

  • BST Users
  • PipPipPipPipPipPipPip
  • 15,417 posts
  • Joined: Feb-15 2005

Posted September 29 2012 - 10:38 AM

Hi! I recently bought a 2005 chevy tahoe......for some odd reason I can't fill my tank. I know this vehicle should take around 22-25 gallons. I can only pump 9-12 gallons before the nozzle pops (indicating my tank is full)....once I start my vehicle it's only on 1/2 tank! which is really frustrating.....can anyone lead me in the right direction to rectify this problem.....thank you.


There are two choices; take more time and put gas in slowly

or

Repair the EVAP system


The first choice costs time, the second, money, your choice.

#8 gomab22

gomab22

    New Member

  • Users
  • Pip
  • 4 posts
  • Joined: Sep-28 2012

Posted September 29 2012 - 10:52 AM


thank you very much.....I will definitely try the evap valve.......but one question? my vehicle is not giving any codes indicating something is wrong or needs to be repaired.....this is a problem I just noticed.....I've only had the truck for a month.



#9 longcaster

longcaster

    Way too many!

  • BST Users
  • PipPipPipPipPipPipPip
  • 15,417 posts
  • Joined: Feb-15 2005

Posted September 29 2012 - 4:30 PM

thank you very much.....I will definitely try the evap valve.......but one question? my vehicle is not giving any codes indicating something is wrong or needs to be repaired.....this is a problem I just noticed.....I've only had the truck for a month.


The vent part of the EVAP is not working, the only vent is out your filler neck. That's why if you go slow it works. The air in the tank has to escape for the gas to have some place to go.

#10 speckhunter80

speckhunter80

    5,000 Post Club!

  • Users
  • PipPipPipPipPipPip
  • 5,620 posts
  • Joined: Jan-17 2008

Posted September 29 2012 - 9:26 PM

Surprised you are not getting a p0445 code when put on a machine

#11 gomab22

gomab22

    New Member

  • Users
  • Pip
  • 4 posts
  • Joined: Sep-28 2012

Posted September 30 2012 - 10:14 AM


Thank you! I will return to the dealership tomorrow and have them run engine codes again.

 



#12 longcaster

longcaster

    Way too many!

  • BST Users
  • PipPipPipPipPipPipPip
  • 15,417 posts
  • Joined: Feb-15 2005

Posted September 30 2012 - 12:45 PM

Thank you! I will return to the dealership tomorrow and have them run engine codes again.

 


What you need to do is show up at the dealer with a quarter tank of gas. Then take the service writer out for a test drive, go to a gas station and start to fill it up, show the service guy your problem.

#13 gomab22

gomab22

    New Member

  • Users
  • Pip
  • 4 posts
  • Joined: Sep-28 2012

Posted October 01 2012 - 8:26 AM


I will do that.....thanks so much.

 



#14 spiegs71

spiegs71

    1,000 Post Club!

  • Users
  • PipPipPipPipPip
  • 3,517 posts
  • Joined: Dec-25 2007

Posted October 03 2012 - 12:00 PM

having the same 'filling the tank' issue with my Xterra

Will have to check and see if its similar to this

#15 speckhunter80

speckhunter80

    5,000 Post Club!

  • Users
  • PipPipPipPipPipPip
  • 5,620 posts
  • Joined: Jan-17 2008

Posted October 03 2012 - 2:49 PM

Got a new 2009 Ford Explorer at the DAV few years ago and very shortly after getting it the gas was EXTREMELY slow to go in. We cussed it especially as it was winter and took forever to fill. Then one day I drove it and gas started running out the filler neck vent. Got the VA approval to take in to a shop and they found a rubber hose in the filler neck. Apparently someone tried to siphon gas and lost the hose.